English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 72022 CVE descriptions
and 38680 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.64634
Category:Debian Local Security Checks
Title:Debian Security Advisory DSA 1855-1 (subversion)
Summary:Debian Security Advisory DSA 1855-1 (subversion)
Description:The remote host is missing an update to subversion
announced via advisory DSA 1855-1.

Matt Lewis discovered that Subversion performs insufficient input
validation of svndiff streams. Malicious servers could cause heap
overflows in clients, and malicious clients with commit access could
cause heap overflows in servers, possibly leading to arbitrary code
execution in both cases.

For the old stable distribution (etch), this problem has been fixed in
version 1.4.2dfsg1-3.

For the stable distribution (lenny), this problem has been fixed in
version 1.5.1dfsg1-4.

For the unstable distribution (sid), this problem has been fixed in
version 1.6.4dfsg-1.

We recommend that you upgrade your Subversion packages.

Solution:
http://www.securityspace.com/smysecure/catid.html?in=DSA%201855-1
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2009-2411
Bugtraq: 20090807 Subversion heap overflow (Google Search)
http://archives.neohapsis.com/archives/bugtraq/2009-08/0056.html
http://svn.haxx.se/dev/archive-2009-08/0110.shtml
http://svn.haxx.se/dev/archive-2009-08/0108.shtml
http://svn.haxx.se/dev/archive-2009-08/0107.shtml
http://lists.apple.com/archives/security-announce/2009/Nov/msg00000.html
Debian Security Information: DSA-1855 (Google Search)
http://www.debian.org/security/2009/dsa-1855
https://www.redhat.com/archives/fedora-package-announce/2009-August/msg00469.html
https://www.redhat.com/archives/fedora-package-announce/2009-August/msg00485.html
http://www.mandriva.com/security/advisories?name=MDVSA-2009:199
http://www.redhat.com/support/errata/RHSA-2009-1203.html
http://www.ubuntu.com/usn/usn-812-1
BugTraq ID: 35983
http://www.securityfocus.com/bid/35983
http://osvdb.org/56856
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11465
http://www.securitytracker.com/id?1022697
http://secunia.com/advisories/36184
http://secunia.com/advisories/36224
http://secunia.com/advisories/36232
http://secunia.com/advisories/36257
http://secunia.com/advisories/36262
http://www.vupen.com/english/advisories/2009/2180
http://www.vupen.com/english/advisories/2009/3184
CopyrightCopyright (c) 2009 E-Soft Inc. http://www.securityspace.com

This is only one of 38680 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.