Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.57662
Category:Red Hat Local Security Checks
Title:RedHat Security Advisory RHSA-2006:0754
Summary:NOSUMMARY
Description:Description:

The remote host is missing updates announced in
advisory RHSA-2006:0754.

GnuPG is a utility for encrypting data and creating digital signatures.

Tavis Ormandy discovered a stack overwrite flaw in the way GnuPG decrypts
messages. An attacker could create carefully crafted message that could cause
GnuPG to execute arbitrary code if a victim attempts to decrypt the message.
(CVE-2006-6235)

A heap based buffer overflow flaw was found in the way GnuPG constructs
messages to be written to the terminal during an interactive session. An
attacker could create a carefully crafted message which with user interaction
could cause GnuPG to execute arbitrary code with the permissions of the
user running GnuPG. (CVE-2006-6169)

All users of GnuPG are advised to upgrade to this updated package, which
contains a backported patch to correct these issues.

Solution:
Please note that this update is available via
Red Hat Network. To use Red Hat Network, launch the Red
Hat Update Agent with the following command: up2date

http://rhn.redhat.com/errata/RHSA-2006-0754.html
http://www.redhat.com/security/updates/classification/#important

Risk factor : Critical

CVSS Score:
10.0

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2006-6169
BugTraq ID: 21306
http://www.securityfocus.com/bid/21306
Bugtraq: 20061127 GnuPG 1.4 and 2.0 buffer overflow (Google Search)
http://www.securityfocus.com/archive/1/452829/100/0/threaded
Bugtraq: 20061201 rPSA-2006-0224-1 gnupg (Google Search)
http://www.securityfocus.com/archive/1/453253/100/100/threaded
Debian Security Information: DSA-1231 (Google Search)
http://www.debian.org/security/2006/dsa-1231
http://security.gentoo.org/glsa/glsa-200612-03.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2006:221
https://bugs.g10code.com/gnupg/issue728
http://lists.gnupg.org/pipermail/gnupg-announce/2006q4/000241.html
http://www.openpkg.com/security/advisories/OpenPKG-SA-2006.037.html
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11228
http://www.redhat.com/support/errata/RHSA-2006-0754.html
http://securitytracker.com/id?1017291
http://secunia.com/advisories/23094
http://secunia.com/advisories/23110
http://secunia.com/advisories/23146
http://secunia.com/advisories/23161
http://secunia.com/advisories/23171
http://secunia.com/advisories/23250
http://secunia.com/advisories/23269
http://secunia.com/advisories/23284
http://secunia.com/advisories/23299
http://secunia.com/advisories/23303
http://secunia.com/advisories/23513
http://secunia.com/advisories/24047
SGI Security Advisory: 20061201-01-P
ftp://patches.sgi.com/support/free/security/advisories/20061201-01-P.asc
http://securityreason.com/securityalert/1927
SuSE Security Announcement: SUSE-SA:2006:075 (Google Search)
http://lists.suse.com/archive/suse-security-announce/2006-Dec/0004.html
http://www.trustix.org/errata/2006/0068/
http://www.ubuntu.com/usn/usn-389-1
http://www.ubuntu.com/usn/usn-393-2
http://www.vupen.com/english/advisories/2006/4736
XForce ISS Database: gnupg-openfile-bo(30550)
https://exchange.xforce.ibmcloud.com/vulnerabilities/30550
Common Vulnerability Exposure (CVE) ID: CVE-2006-6235
BugTraq ID: 21462
http://www.securityfocus.com/bid/21462
Bugtraq: 20061206 GnuPG: remotely controllable function pointer [CVE-2006-6235] (Google Search)
http://www.securityfocus.com/archive/1/453664/100/0/threaded
Bugtraq: 20061206 rPSA-2006-0227-1 gnupg (Google Search)
http://www.securityfocus.com/archive/1/453723/100/0/threaded
CERT/CC vulnerability note: VU#427009
http://www.kb.cert.org/vuls/id/427009
http://www.mandriva.com/security/advisories?name=MDKSA-2006:228
http://lists.gnupg.org/pipermail/gnupg-announce/2006q4/000491.html
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11245
http://securitytracker.com/id?1017349
http://secunia.com/advisories/23245
http://secunia.com/advisories/23255
http://secunia.com/advisories/23259
http://secunia.com/advisories/23290
http://secunia.com/advisories/23329
http://secunia.com/advisories/23335
SuSE Security Announcement: SUSE-SR:2006:028 (Google Search)
http://www.novell.com/linux/security/advisories/2006_28_sr.html
http://www.trustix.org/errata/2006/0070
http://www.ubuntu.com/usn/usn-393-1
http://www.vupen.com/english/advisories/2006/4881
XForce ISS Database: gnupg-openpgp-code-execution(30711)
https://exchange.xforce.ibmcloud.com/vulnerabilities/30711
CopyrightCopyright (c) 2006 E-Soft Inc. http://www.securityspace.com

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.