English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 74154 CVE descriptions
and 39337 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.55977
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-224-1 (krb5)
Summary:Ubuntu USN-224-1 (krb5)
Description:
The remote host is missing an update to krb5
announced via advisory USN-224-1.

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)
Ubuntu 5.04 (Hoary Hedgehog)

The following packages are affected:

kerberos4kth-clients
krb5-clients
krb5-kdc
krb5-rsh-server
krb5-telnetd

Gal Delalleau discovered a buffer overflow in the env_opt_add()
function of the Kerberos 4 and 5 telnet clients. By sending specially
crafted replies, a malicious telnet server could exploit this to
execute arbitrary code with the privileges of the user running the
telnet client. (CVE-2005-0468)

Gal Delalleau discovered a buffer overflow in the handling of the
LINEMODE suboptions in the telnet clients of Kerberos 4 and 5. By
sending a specially constructed reply containing a large number of SLC
(Set Local Character) commands, a remote attacker (i. e. a malicious
telnet server) could execute arbitrary commands with the privileges of
the user running the telnet client. (CVE-2005-0469)

Daniel Wachdorf discovered two remote vulnerabilities in the Key
Distribution Center of Kerberos 5 (krb5-kdc). By sending certain TCP
connection requests, a remote attacker could trigger a double-freeing
of memory, which led to memory corruption and a crash of the KDC
server. (CVE-2005-1174). Under rare circumstances the same type of TCP
connection requests could also trigger a buffer overflow that could be
exploited to run arbitrary code with the privileges of the KDC server.
(CVE-2005-1175)

Magnus Hagander discovered that the krb5_recvauth() function attempted
to free previously freed memory in some situations. A remote attacker
could possibly exploit this to run arbitrary code with the privileges
of the program that called this function. Most imporantly, this
affects the following daemons: kpropd (from the krb5-kdc package),
klogind, and kshd (both from the krb5-rsh-server package).
(CVE-2005-1689)

Please note that these packages are not officially supported by Ubuntu
(they are in the 'universe' component of the archive).

Solution:
On Ubuntu 4.10, the problem can be corrected by upgrading the affected
package to version 1.2.2-10ubuntu0.1 (kerberos4kth-clients), and
1.3.4-3ubuntu0.2 (krb5-clients, krb5-kdc, krb5-rsh-server,
krb5-telnetd).

On Ubuntu 5.04, the problem can be corrected by upgrading the affected
package to version 1.2.2-10ubuntu0.1 (kerberos4kth-client ), and
1.3.6-1ubuntu0.1 (krb5-clients, krb5-kdc, krb5-rsh-server,
krb5-telnetd).

In general, a standard system upgrade is sufficient to effect the
necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-224-1

Risk factor : High
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2005-0468
http://www.idefense.com/application/poi/display?id=221&type=vulnerabilities
Conectiva Linux advisory: CLA-2005:962
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000962
Debian Security Information: DSA-703 (Google Search)
http://www.debian.org/security/2005/dsa-703
Debian Security Information: DSA-731 (Google Search)
http://www.debian.de/security/2005/dsa-731
FreeBSD Security Advisory: FreeBSD-SA-05:01.telnet
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-05:01.telnet.asc
http://www.mandriva.com/security/advisories?name=MDKSA-2005:061
http://www.redhat.com/support/errata/RHSA-2005-327.html
http://www.redhat.com/support/errata/RHSA-2005-330.html
SGI Security Advisory: 20050405-01-P
ftp://patches.sgi.com/support/free/security/advisories/20050405-01-P
http://sunsolve.sun.com/search/document.do?assetkey=1-26-57755-1
http://sunsolve.sun.com/search/document.do?assetkey=1-26-57761-1
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101671-1
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101665-1
http://www.ubuntulinux.org/usn/usn-224-1
CERT/CC vulnerability note: VU#341908
http://www.kb.cert.org/vuls/id/341908
BugTraq ID: 12919
http://www.securityfocus.com/bid/12919
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9640
http://secunia.com/advisories/14745
http://secunia.com/advisories/17899
Common Vulnerability Exposure (CVE) ID: CVE-2005-0469
http://www.idefense.com/application/poi/display?id=220&type=vulnerabilities
Debian Security Information: DSA-697 (Google Search)
http://www.debian.org/security/2005/dsa-697
Debian Security Information: DSA-699 (Google Search)
http://www.debian.org/security/2005/dsa-699
http://www.gentoo.org/security/en/glsa/glsa-200503-36.xml
CERT/CC vulnerability note: VU#291924
http://www.kb.cert.org/vuls/id/291924
BugTraq ID: 12918
http://www.securityfocus.com/bid/12918
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9708
Common Vulnerability Exposure (CVE) ID: CVE-2005-1174
Bugtraq: 20050712 MITKRB5-SA-2005-002: buffer overflow, heap corruption in KDC (Google Search)
http://marc.theaimsgroup.com/?l=bugtraq&m=112122123211974&w=2
AIX APAR: IY85474
http://www-1.ibm.com/support/docview.wss?uid=swg1IY85474
http://lists.apple.com/archives/security-announce/2005/Aug/msg00000.html
http://lists.apple.com/archives/security-announce/2005//Aug/msg00001.html
Debian Security Information: DSA-757 (Google Search)
http://www.debian.org/security/2005/dsa-757
http://www.redhat.com/support/errata/RHSA-2005-567.html
SGI Security Advisory: 20050703-01-U
ftp://patches.sgi.com/support/free/security/advisories/20050703-01-U.asc
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101809-1
SuSE Security Announcement: SUSE-SR:2005:017 (Google Search)
http://www.novell.com/linux/security/advisories/2005_17_sr.html
TurboLinux Advisory: TLSA-2005-78
http://www.turbolinux.com/security/2005/TLSA-2005-78.txt
http://www.trustix.org/errata/2005/0036
http://www.ubuntulinux.org/support/documentation/usn/usn-224-1
CERT/CC vulnerability note: VU#259798
http://www.kb.cert.org/vuls/id/259798
BugTraq ID: 14240
http://www.securityfocus.com/bid/14240
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10229
http://www.vupen.com/english/advisories/2005/1066
http://www.vupen.com/english/advisories/2006/2074
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:397
http://securitytracker.com/id?1014460
http://secunia.com/advisories/16041
http://secunia.com/advisories/20364
XForce ISS Database: kerberos-kdc-krb5-tcp-connection-dos(21327)
http://xforce.iss.net/xforce/xfdb/21327
Common Vulnerability Exposure (CVE) ID: CVE-2005-1175
http://www.redhat.com/support/errata/RHSA-2005-562.html
CERT/CC vulnerability note: VU#885830
http://www.kb.cert.org/vuls/id/885830
BugTraq ID: 14236
http://www.securityfocus.com/bid/14236
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9902
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:736
http://secunia.com/advisories/17135
XForce ISS Database: kerberos-kdc-krb5-udp-tcp-bo(21328)
http://xforce.iss.net/xforce/xfdb/21328
Common Vulnerability Exposure (CVE) ID: CVE-2005-1689
Bugtraq: 20050712 MITKRB5-SA-2005-003: double-free in krb5_recvauth (Google Search)
http://marc.theaimsgroup.com/?l=bugtraq&m=112119974704542&w=2
Conectiva Linux advisory: CLA-2005:993
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000993
http://www.gentoo.org/security/en/glsa/glsa-200507-11.xml
HPdes Security Advisory: HPSBUX02152
http://www.securityfocus.com/archive/1/archive/1/446940/100/0/threaded
HPdes Security Advisory: SSRT5973
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101810-1
CERT/CC vulnerability note: VU#623332
http://www.kb.cert.org/vuls/id/623332
BugTraq ID: 14239
http://www.securityfocus.com/bid/14239
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9819
http://www.vupen.com/english/advisories/2006/3776
http://securitytracker.com/id?1014461
http://secunia.com/advisories/22090
XForce ISS Database: kerberos-kdc-krb5recvauth-execute-code(21055)
http://xforce.iss.net/xforce/xfdb/21055
CopyrightCopyright (c) 2005 E-Soft Inc. http://www.securityspace.com

This is only one of 39337 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.