Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.51026
Category:Red Hat Local Security Checks
Title:RedHat Security Advisory RHSA-2003:257
Summary:NOSUMMARY
Description:Description:

The remote host is missing updates announced in
advisory RHSA-2003:257.

Perl is a high-level programming language commonly used for system
administration utilities and Web programming.

Two security issues have been found in Perl that affect the Perl packages
shipped with Red Hat Enterprise Linux:

When safe.pm versions 2.0.7 and earlier are used with Perl 5.8.0 and
earlier, it is possible for an attacker to break out of safe compartments
within Safe::reval and Safe::rdo by using a redefined @_ variable. This is
due to the fact that the redefined @_ variable is not reset between
successive calls. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2002-1323 to this issue.

A cross-site scripting vulnerability was discovered in the start_form()
function of CGI.pm. The vulnerability allows a remote attacker to insert a
Web script via a URL fed into the form's action parameter. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name
CVE-2003-0615 to this issue.

Users of Perl are advised to upgrade to these erratum packages, which
contain Perl 5.6.1 with backported security patches correcting these issues.

Solution:
Please note that this update is available via
Red Hat Network. To use Red Hat Network, launch the Red
Hat Update Agent with the following command: up2date

http://rhn.redhat.com/errata/RHSA-2003-257.html
http://marc.theaimsgroup.com/?l=bugtraq&m=105880349328877
http://bugs6.perl.org/rt2/Ticket/Display.html?id=17744

Risk factor : Medium

CVSS Score:
4.6

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2002-1323
BugTraq ID: 6111
http://www.securityfocus.com/bid/6111
Bugtraq: 20021216 [OpenPKG-SA-2002.014] OpenPKG Security Advisory (perl) (Google Search)
http://marc.info/?l=bugtraq&m=104005919814869&w=2
Bugtraq: 20021219 TSLSA-2002-0087 - perl (Google Search)
http://marc.info/?l=bugtraq&m=104033126305252&w=2
Bugtraq: 20021220 GLSA: perl (Google Search)
http://marc.info/?l=bugtraq&m=104040175522502&w=2
Caldera Security Advisory: CSSA-2004-007.0
ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2004-007.0.txt
Debian Security Information: DSA-208 (Google Search)
http://www.debian.org/security/2002/dsa-208
http://www.osvdb.org/2183
http://www.osvdb.org/3814
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A1160
http://www.redhat.com/support/errata/RHSA-2003-256.html
http://www.redhat.com/support/errata/RHSA-2003-257.html
SCO Security Bulletin: SCOSA-2004.1
ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.1/SCOSA-2004.1.txt
SGI Security Advisory: 20030606-01-A
ftp://patches.sgi.com/support/free/security/advisories/20030606-01-A
http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0061.html
http://www.iss.net/security_center/static/10574.php
Common Vulnerability Exposure (CVE) ID: CVE-2003-0615
BugTraq ID: 8231
http://www.securityfocus.com/bid/8231
Bugtraq: 20030720 CGI.pm vulnerable to Cross-site Scripting (Google Search)
http://marc.info/?l=bugtraq&m=105880349328877&w=2
Bugtraq: 20030806 [OpenPKG-SA-2003.036] OpenPKG Security Advisory (perl-www) (Google Search)
http://marc.info/?l=bugtraq&m=106018783704468&w=2
CERT/CC vulnerability note: VU#246409
http://www.kb.cert.org/vuls/id/246409
Computer Incident Advisory Center Bulletin: N-155
http://www.ciac.org/ciac/bulletins/n-155.shtml
Conectiva Linux advisory: CLA-2003:713
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000713
Debian Security Information: DSA-371 (Google Search)
http://www.debian.org/security/2003/dsa-371
http://marc.info/?l=full-disclosure&m=105875211018698&w=2
http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2003:084
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A307
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A470
SCO Security Bulletin: CSSA-2003-SCO.30
http://securitytracker.com/id?1007234
http://secunia.com/advisories/13638
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101426-1
XForce ISS Database: cgi-startform-xss(12669)
https://exchange.xforce.ibmcloud.com/vulnerabilities/12669
CopyrightCopyright (c) 2005 E-Soft Inc. http://www.securityspace.com

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.