Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.144912
Category:Web application abuses
Title:MoinMoin < 1.9.11 Multiple Vulnerabilities (Linux)
Summary:MoinMoin is prone to multiple vulnerabilities.
Description:Summary:
MoinMoin is prone to multiple vulnerabilities.

Vulnerability Insight:
The following vulnerabilities exist:

- The cache action in action/cache.py allows directory traversal through a crafted HTTP request (CVE-2020-25074)

- Malicious SVG attachment causing stored cross-site scripting (XSS) (CVE-2020-15275)

Vulnerability Impact:
- An attacker who can upload attachments to the wiki can use this to achieve
remote code execution (CVE-2020-25074)

- An attacker with write permissions can upload an SVG file that contains malicious javascript. This javascript
will be executed in a user's browser when the user is viewing that SVG file on the wiki. (CVE-2020-15275)

Affected Software/OS:
MoinMoin prior to version 1.9.11.

Solution:
Update to version 1.9.11 or later.

CVSS Score:
6.5

CVSS Vector:
AV:N/AC:L/Au:S/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-25074
Common Vulnerability Exposure (CVE) ID: CVE-2020-15275
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.