Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.143941
Category:Denial of Service
Title:Knot Resolver < 5.1.1 NXNSAttack Vulnerability
Summary:Knot Resolver is prone to a denial of service vulnerability (NXNSAttack).
Description:Summary:
Knot Resolver is prone to a denial of service vulnerability (NXNSAttack).

Vulnerability Insight:
Knot Resolver allows traffic amplification via a crafted DNS answer from
an attacker-controlled server, aka an 'NXNSAttack' issue. This is triggered by random subdomains in the
NSDNAME in NS records.

Affected Software/OS:
Knot Resolver prior to version 5.1.1.

Solution:
Update to version 5.1.1 or later.

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-12667
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.