Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.143885
Category:Web application abuses
Title:Nextcloud Server 18.x < 18.0.3 XSS Vulnerability (NC-SA-2020-019)
Summary:Nextcloud Server is prone to a cross-site scripting vulnerability in the; Files PDF viewer.
Description:Summary:
Nextcloud Server is prone to a cross-site scripting vulnerability in the
Files PDF viewer.

Vulnerability Insight:
An outdated 3rd party library in the Files PDF viewer for Nextcloud Server
caused a Cross-site scripting vulnerability when opening a malicious PDF.

Affected Software/OS:
Nextcloud server versions 18.x.

Solution:
Update to version 18.0.3 or later.

CVSS Score:
3.5

CVSS Vector:
AV:N/AC:M/Au:S/C:N/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-8155
https://nextcloud.com/security/advisory/?id=NC-SA-2020-019
SuSE Security Announcement: openSUSE-SU-2020:0667 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00037.html
SuSE Security Announcement: openSUSE-SU-2020:0668 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00038.html
SuSE Security Announcement: openSUSE-SU-2020:0670 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00040.html
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.