Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.117029
Category:General
Title:OpenSSL 0.9.8 Information Disclosure Vulnerability
Summary:OpenSSL is prone to an information disclosure vulnerability.
Description:Summary:
OpenSSL is prone to an information disclosure vulnerability.

Vulnerability Insight:
The Diffie-Hellman key-exchange implementation in OpenSSL,
when FIPS mode is enabled, does not properly validate a public parameter.

Vulnerability Impact:
This flaw makes it easier for man-in-the-middle attackers to
obtain the shared secret key by modifying network traffic.

Affected Software/OS:
OpenSSL 0.9.8, when FIPS mode is enabled.

Solution:
Update OpenSSL to a later version or disable FIPS mode.

CVSS Score:
4.0

CVSS Vector:
AV:N/AC:H/Au:N/C:P/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2011-5095
http://www.cl.cam.ac.uk/~rja14/Papers/psandqs.pdf
http://www.nessus.org/plugins/index.php?view=single&id=53360
https://discussions.nessus.org/thread/3381
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.