Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.112820
Category:Web application abuses
Title:WordPress Lara's Google Analytics Plugin < 2.0.5 XSS Vulnerability
Summary:The WordPress plugin Lara's Google Analytics is prone to a cross-site scripting (XSS) vulnerability.
Description:Summary:
The WordPress plugin Lara's Google Analytics is prone to a cross-site scripting (XSS) vulnerability.

Vulnerability Insight:
In the main 'lara-google-analytics.php' script, the 'lrgawidget_setProfileID'
action is used to call the 'lrgawidget_callback' function via the WordPress AJAX API.
Attackers can use it to inject JavaScript code in the 'property_id' field. It is injected into all pages and posts of the CMS.

Vulnerability Impact:
Successful exploitation would allow an attacker to
inject arbitrary script code into an affected site.

Affected Software/OS:
WordPress Lara's Google Analytics plugin through version 2.0.4.

Solution:
Update to version 2.0.5 or later.

CVSS Score:
3.5

CVSS Vector:
AV:N/AC:M/Au:S/C:N/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-20626
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.