Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.112738
Category:Web application abuses
Title:WordPress LearnPress Plugin < 3.2.6.7 Multiple Privilege Escalation Vulnerabilities
Summary:LearnPress plugin for WordPress is prone to multiple privilege escalation vulnerabilities.
Description:Summary:
LearnPress plugin for WordPress is prone to multiple privilege escalation vulnerabilities.

Vulnerability Insight:
The vulnerabilities exist due to missing permission checks in the 'be_teacher' function in 'class-lp-admin-ajax.php'.

Vulnerability Impact:
A remote authenticated attacker can assign itself the instructor/teacher role and gain access to otherwise restricted data.

Affected Software/OS:
WordPress LearnPress plugin before version 3.2.6.7.

Solution:
Update to version 3.2.6.7 or later.

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:S/C:C/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-7916
Common Vulnerability Exposure (CVE) ID: CVE-2020-7917
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.