Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2020-8945
Description:The proglottis Go wrapper before 0.1.1 for the GPGME library has a use-after-free, as demonstrated by use for container image pulls by Docker or CRI-O. This leads to a crash or potential code execution during GPG signature verification.
Test IDs: 1.3.6.1.4.1.25623.1.0.877500   1.3.6.1.4.1.25623.1.0.877552   1.3.6.1.4.1.25623.1.0.877508   1.3.6.1.4.1.25623.1.1.2.2020.1290  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2020-8945
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KDBT77KV3U7BESJX3P4S4MPVDGRTAQA2/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3SOCLOPTSYABTE4CLTSPDIFE6ZZZR4LX/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WXV7NZELYWRRCXATXU3FYD3G3WJT3WYM/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/H6P6SSNKN4H6GSEVROHBDXA64PX7EOED/
https://bugzilla.redhat.com/show_bug.cgi?id=1795838
https://github.com/containers/image/commit/4c7a23f82ef09127b0ff28366d1cf31316dd6cc1
https://github.com/proglottis/gpgme/compare/v0.1.0...v0.1.1
https://github.com/proglottis/gpgme/pull/23
RedHat Security Advisories: RHSA-2020:0679
https://access.redhat.com/errata/RHSA-2020:0679
RedHat Security Advisories: RHSA-2020:0689
https://access.redhat.com/errata/RHSA-2020:0689
RedHat Security Advisories: RHSA-2020:0697
https://access.redhat.com/errata/RHSA-2020:0697




© 1998-2021 E-Soft Inc. All rights reserved.