Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2019-9499
Description:The implementations of EAP-PWD in wpa_supplicant EAP Peer, when built against a crypto library missing explicit validation on imported elements, do not validate the scalar and element values in EAP-pwd- Commit. An attacker may complete authentication, session key and control of the data connection with a client. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.
Test IDs: 1.3.6.1.4.1.25623.1.0.704430   1.3.6.1.4.1.25623.1.0.891867  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2019-9499
Bugtraq: 20190515 FreeBSD Security Advisory FreeBSD-SA-19:03.wpa (Google Search)
https://seclists.org/bugtraq/2019/May/40
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/56OBBOJJSKRTDGEXZOVFSTP4HDSDBLAE/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SVMJOFEYBGXZLFF5IOLW67SSOPKFEJP3/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TDOZGR3T7FVO5JSZWK2QPR7AOFIEJTIZ/
FreeBSD Security Advisory: FreeBSD-SA-19:03
https://security.FreeBSD.org/advisories/FreeBSD-SA-19:03.wpa.asc
https://lists.debian.org/debian-lts-announce/2019/07/msg00030.html
SuSE Security Announcement: openSUSE-SU-2020:0222 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00021.html




© 1998-2021 E-Soft Inc. All rights reserved.