Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2010-4015
Description:Buffer overflow in the gettoken function in contrib/intarray/_int_bool.c in the intarray array module in PostgreSQL 9.0.x before 9.0.3, 8.4.x before 8.4.7, 8.3.x before 8.3.14, and 8.2.x before 8.2.20 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via integers with a large number of digits to unspecified functions.
Test IDs: 1.3.6.1.4.1.25623.1.0.68975   1.3.6.1.4.1.25623.1.0.68861   1.3.6.1.4.1.25623.1.0.68841   1.3.6.1.4.1.25623.1.0.68870   1.3.6.1.4.1.25623.1.0.68869   1.3.6.1.4.1.25623.1.0.69186   1.3.6.1.4.1.25623.1.0.69625   1.3.6.1.4.1.25623.1.0.103054   1.3.6.1.4.1.25623.1.0.122273   1.3.6.1.4.1.25623.1.0.122272   1.3.6.1.4.1.25623.1.0.880527   1.3.6.1.4.1.25623.1.0.881354   1.3.6.1.4.1.25623.1.0.880562   1.3.6.1.4.1.25623.1.0.870389   1.3.6.1.4.1.25623.1.0.881376   1.3.6.1.4.1.25623.1.0.881292   1.3.6.1.4.1.25623.1.0.831321   1.3.6.1.4.1.25623.1.0.880471   1.3.6.1.4.1.25623.1.0.870387   1.3.6.1.4.1.25623.1.0.862845   1.3.6.1.4.1.25623.1.0.840577  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2010-4015
BugTraq ID: 46084
http://www.securityfocus.com/bid/46084
Debian Security Information: DSA-2157 (Google Search)
http://www.debian.org/security/2011/dsa-2157
http://lists.fedoraproject.org/pipermail/package-announce/2011-February/053888.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-February/053817.html
HPdes Security Advisory: HPSBMU02781
http://marc.info/?l=bugtraq&m=134124585221119&w=2
HPdes Security Advisory: SSRT100617
http://marc.info/?l=bugtraq&m=134124585221119&w=2
http://www.mandriva.com/security/advisories?name=MDVSA-2011:021
http://osvdb.org/70740
RedHat Security Advisories: RHSA-2011:0197
http://www.redhat.com/support/errata/RHSA-2011-0197.html
RedHat Security Advisories: RHSA-2011:0198
http://www.redhat.com/support/errata/RHSA-2011-0198.html
http://secunia.com/advisories/43144
http://secunia.com/advisories/43154
http://secunia.com/advisories/43155
http://secunia.com/advisories/43187
http://secunia.com/advisories/43188
http://secunia.com/advisories/43240
SuSE Security Announcement: SUSE-SR:2011:005 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2011-04/msg00000.html
http://www.ubuntu.com/usn/USN-1058-1
http://www.vupen.com/english/advisories/2011/0262
http://www.vupen.com/english/advisories/2011/0278
http://www.vupen.com/english/advisories/2011/0283
http://www.vupen.com/english/advisories/2011/0287
http://www.vupen.com/english/advisories/2011/0299
http://www.vupen.com/english/advisories/2011/0303
http://www.vupen.com/english/advisories/2011/0349
XForce ISS Database: postgresql-gettoken-buffer-overflow(65060)
https://exchange.xforce.ibmcloud.com/vulnerabilities/65060




© 1998-2021 E-Soft Inc. All rights reserved.