English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 143769 CVE descriptions
and 71225 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Trustix Secure Linux Security Advisory #2006-0030

Package names:    kernel, quagga 
Summary:           Multiple vulnerabilities
Date:              2006-05-26
Affected versions: Trustix Secure Linux 3.0

- --------------------------------------------------------------------------
Package description:
  kernel
  The kernel package contains the Linux kernel (vmlinuz), the core of your
  Trustix Secure Linux operating system.  The kernel handles the basic
  functions of the operating system:  memory allocation, process allocation,
  device input and output, etc.

  quagga 
  Quagga is a free software that manages TCP/IP based routing protocol.
  It takes multi-server and multi-thread approach to resolve the current
  complexity of the Internet. 

Problem description:
  kernel < TSL 3.0 >
  - New Upstream.
  - SECURITY Fix: A race condition in the "do_add_counters()" function
    in netfilter can be exploited by local users to read kernel memory
    or cause the system to crash via a race condition that produces a
    size value that is different from the size of the allocated memory.
  - An input validation error in SCTP when processing a HB-ACK chunk
    with a specially-crafted parameter length can be exploited to cause
    out-of-bounds memory access. This can potentially cause the system
    to crash.
  - An error in SCTP chunk length calculation during parameter
    processing can be exploited to cause out-of-bounds memory access.
    This can potentially cause the system to crash.
  - A vulnerability has been reported which is caused due to some errors
    within the "snmp_trap_decode()" function when handling certain SNMP
    packets. This can be exploited to cause memory corruption due to
    incorrect freeing of memory, which can potentially cause the system
    to crash.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the names CVE-2006-0039, CVE-2006-1857, CVE-2006-1858
    and CVE-2006-2444 to these issue.

  quagga < TSL 3.0 > 
  - New Upstream.
  - SECURITY Fix: Konstantin V. Gavrilenko has reported two security
    issues in Quagga, which can be exploited by malicious people to bypass
    certain security restrictions and to disclose system information.
  - An error in RIPd does not properly implement configurations that 
    1) disable RIPv1 or 2) require plaintext or MD5 authentication. This allows
    remote attackers to obtain sensitive information via REQUEST packets
    such as SEND UPDATE.
  - An error in RIPd does not properly enforce RIPv2 authentication
    requirements. This allows remote attackers to modify routing state via
    RIPv1 RESPONSE packets.
  - Fredrik Widell has reported a vulnerability in Quagga caused due to an
    infinite loop error in bgpd within the "community_str2com()" function.
    This can be exploited to cause the process to consume large amounts of
    CPU resources by issuing the "sh ip bgp command" command via the telnet
    management interface.

    The Common Vulnerabilities and Exposures project (cve.mitre.org) has
    assigned the names CVE-2006-2223, CVE-2006-2224 and CVE-2006-2276 to
    these issues.

Action:
  We recommend that all systems with this package installed be upgraded.
  Please note that if you do not need the functionality provided by this
  package, you may want to remove it from your system.


Location:
  All Trustix Secure Linux updates are available from
  <URI:http://http.trustix.org/pub/trustix/updates/>
  <URI:ftp://ftp.trustix.org/pub/trustix/updates/>


About Trustix Secure Linux:
  Trustix Secure Linux is a small Linux distribution for servers. With focus
  on security and stability, the system is painlessly kept safe and up to
  date from day one using swup, the automated software updater.


Automatic updates:
  Users of the SWUP tool can enjoy having updates automatically
  installed using 'swup --upgrade'.


Questions?
  Check out our mailing lists:
  <URI:http://www.trustix.org/support/>


Verification:
  This advisory along with all Trustix packages are signed with the
  TSL sign key.
  This key is available from:
  <URI:http://www.trustix.org/TSL-SIGN-KEY>

  The advisory itself is available from the errata pages at
  <URI:http://www.trustix.org/errata/trustix-2.2/> and
  <URI:http://www.trustix.org/errata/trustix-3.0/>
  or directly at
  <URI:http://www.trustix.org/errata/2006/0030/>


MD5sums of the packages:
- --------------------------------------------------------------------------
26da229a02821f6e14e905a282389ec9  3.0/rpms/kernel-2.6.16.18-1tr.i586.rpm
5c1883600c25d03f3e86db4fd22ec247  3.0/rpms/kernel-doc-2.6.16.18-1tr.i586.rpm
9d0da7bd68da7e994a9f749bd2011a5f  3.0/rpms/kernel-headers-2.6.16.18-1tr.i586.rpm
419200e34a1905185fe775c99cfb6f19  3.0/rpms/kernel-smp-2.6.16.18-1tr.i586.rpm
6f07a7a406b40ff84455d125e2170611  3.0/rpms/kernel-smp-headers-2.6.16.18-1tr.i586.rpm
aab5ab7c61b4f3669a762ec25b2cf57e  3.0/rpms/kernel-source-2.6.16.18-1tr.i586.rpm
b577b074ebde3728e1d8d745d7bd3b63  3.0/rpms/kernel-utils-2.6.16.18-1tr.i586.rpm
2f91f16055bedbd2b961da2e6b337f98  3.0/rpms/quagga-0.98.6-1tr.i586.rpm
8f99fee94a7619e79a951bbddbf572d5  3.0/rpms/quagga-contrib-0.98.6-1tr.i586.rpm
7c76e894aeacec9ceaf0a24427705c10  3.0/rpms/quagga-devel-0.98.6-1tr.i586.rpm
- --------------------------------------------------------------------------


Trustix Security Team


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFEdvlXi8CEzsK9IksRAs6+AJ46VB/nNLyAWJu8gTl9aivQUAT7FgCfTceJ
PzgAlMV7oTsUM+2kGBBvPVs=
=tfKa
-----END PGP SIGNATURE-----

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe

© 1998-2019 E-Soft Inc. All rights reserved.