English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 143769 CVE descriptions
and 71225 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: scsi-target-utils security update
Advisory ID:       RHSA-2010:0518-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2010-0518.html
Issue date:        2010-07-08
CVE Names:         CVE-2010-2221 
=====================================================================

1. Summary:

An updated scsi-target-utils package that fixes multiple security issues is
now available for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having
important security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from the
CVE link in the References section.

2. Relevant releases/architectures:

RHEL Cluster-Storage (v. 5 server) - i386, ia64, ppc, x86_64

3. Description:

The scsi-target-utils package contains the daemon and tools to set up and
monitor SCSI targets. Currently, iSCSI software and iSER targets are
supported.

Multiple buffer overflow flaws were found in scsi-target-utils' tgtd
daemon. A remote attacker could trigger these flaws by sending a
carefully-crafted Internet Storage Name Service (iSNS) request, causing the
tgtd daemon to crash. (CVE-2010-2221)

Red Hat would like to thank the Vulnerability Research Team at TELUS
Security Labs and Fujita Tomonori for responsibly reporting these flaws.

All scsi-target-utils users should upgrade to this updated package, which
contains a backported patch to correct these issues. All running
scsi-target-utils services must be restarted for the update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

593877 - CVE-2010-2221 scsi-target-utils: stack buffer overflow vulnerability

6. Package List:

RHEL Cluster-Storage (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/scsi-target-utils-0.0-6.20091205snap.el5_5.3.src.rpm

i386:
scsi-target-utils-0.0-6.20091205snap.el5_5.3.i386.rpm
scsi-target-utils-debuginfo-0.0-6.20091205snap.el5_5.3.i386.rpm

ia64:
scsi-target-utils-0.0-6.20091205snap.el5_5.3.ia64.rpm
scsi-target-utils-debuginfo-0.0-6.20091205snap.el5_5.3.ia64.rpm

ppc:
scsi-target-utils-0.0-6.20091205snap.el5_5.3.ppc.rpm
scsi-target-utils-debuginfo-0.0-6.20091205snap.el5_5.3.ppc.rpm

x86_64:
scsi-target-utils-0.0-6.20091205snap.el5_5.3.x86_64.rpm
scsi-target-utils-debuginfo-0.0-6.20091205snap.el5_5.3.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-2221.html
http://www.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFMNfM9XlSAg2UNWIIRAkdoAJ4jofX1Rz7DQvvbtBwz+Q3qs/5/uACgjYtF
Dco4MBmubo5Cm0s8jO5FX3I=
=nH43
-----END PGP SIGNATURE-----

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe

© 1998-2019 E-Soft Inc. All rights reserved.