English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 102521 CVE descriptions
and 54701 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2008-6025
2008-07-03 00:41:54
--------------------------------------------------------------------------------

Name        : glib2
Product     : Fedora 8
Version     : 2.14.6
Release     : 2.fc8
URL         : http://www.gtk.org
Summary     : A library of handy utility functions
Description :
GLib is the low-level core library that forms the basis
for projects such as GTK+ and GNOME. It provides data structure
handling for C, portability wrappers, and interfaces for such runtime
functionality as an event loop, threads, dynamic loading, and an
object system.

This package provides version 2 of GLib.

--------------------------------------------------------------------------------
Update Information:

This update fixes a heap-based overflow caused by incorrect option handling in
pcre (CVE-2008-2371)
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul  2 2008 Matthias Clasen <mclasen@redhat.com> - 2.14.6-2
- Fix a heap-based buffer overflow in PCRE (CVE-2008-2371)
* Thu Feb  7 2008 Matthias Clasen <mclasen@redhat.com> - 2.14.6-1
- Update to 2.14.6 (fixes a buffer overflow in PCRE)
* Mon Jan  7 2008 Matthias Clasen <mclasen@redhat.com> - 2.14.5-1
- Update to 2.14.5
* Sat Nov 24 2007 Matthias Clasen <mclasen@redhat.com> - 2.14.4-1
- Update to 2.14.4
* Wed Nov  7 2007 Matthias Clasen <mclasen@redhat.com> - 2.14.3-1
- Update to 2.14.3, including a new version of PCRE that
  fixes several vulnerabilities
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #452079 - CVE-2008-2371 pcre: heap overflow caused by incorrect option handling
        https://bugzilla.redhat.com/show_bug.cgi?id=452079
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update glib2' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------

_______________________________________________
Fedora-package-announce mailing list
Fedora-package-announce@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-package-announce

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2017 E-Soft Inc. All rights reserved.