English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 75803 CVE descriptions
and 40037 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.800004
Category:Privilege escalation
Title:VMware Tools Local Privilege Escalation Vulnerability (Win)
Summary:Check for the version of VMware Products
Description:

Overview : The host is installed with VMWare product(s) that are vulnerable
to local privilege escalation vulnerability.

Vulnerability Insight:
An input validation error is present in the Windows-based VMware HGFS.sys
driver. Exploitation of this flaw might result in arbitrary code execution
on the guest system by an unprivileged guest user. The HGFS.sys driver is
present in the guest operating system if the VMware Tools package is loaded
on Windows based Guest OS.

Impact: Successful exploitation could result in guest OS users to modify
arbitrary memory locations in guest kernel memory and gain privileges.

Impact Level : System

Affected Software/OS :
VMware ACE 1.x - 1.0.5 build 79846 on Windows
VMware Player 1.x - before 1.0.6 build 80404 on Windows
VMware Server 1.x - before 1.0.5 build 80187 on Windows
VMware Workstation 5.x - before 5.5.6 build 80404 on Windows

Fix:
Upgrade VMware Product(s) to below version,
VMware ACE 1.0.5 build 79846 or later
www.vmware.com/download/ace/

VMware Player 1.0.6 build 80404 or later
www.vmware.com/download/player/

VMware Server 1.0.5 build 80187 or later
www.vmware.com/download/server/

VMware Workstation 5.5.6 build 80404 or later
www.vmware.com/download/ws/

References : http://secunia.com/advisories/30556
http://www.vmware.com/security/advisories/VMSA-2008-0009.html
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2007-5671
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=712
Bugtraq: 20080604 VMSA-2008-0009 Updates to VMware Workstation, VMware Player, VMware ACE, VMware Fusion, VMware Server, VMware VIX API, VMware ESX, VMware ESXi resolve critical security issues (Google Search)
http://www.securityfocus.com/archive/1/archive/1/493080/100/0/threaded
Bugtraq: 20080606 Re: iDefense Security Advisory 06.04.08: VMware Tools HGFS Local Privilege Escalation Vulnerability (Google Search)
http://www.securityfocus.com/archive/1/archive/1/493148/100/0/threaded
http://www.securityfocus.com/archive/1/archive/1/493172/100/0/threaded
http://security.gentoo.org/glsa/glsa-201209-25.xml
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:5358
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:5688
http://www.vupen.com/english/advisories/2008/1744
http://securitytracker.com/id?1020197
http://secunia.com/advisories/30556
http://securityreason.com/securityalert/3922
CopyrightCopyright (C) 2008 Greenbone Networks GmbH

This is only one of 40037 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.