English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 72151 CVE descriptions
and 38907 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.56840
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-288-1 (python-pgsql)
Summary:Ubuntu USN-288-1 (python-pgsql)
Description:
The remote host is missing an update to python-pgsql
announced via advisory USN-288-1.

A security issue affects the following Ubuntu releases:

Ubuntu 5.04 (Hoary Hedgehog)
Ubuntu 5.10 (Breezy Badger)

The following packages are affected: libpq3 libpq4 postgresql
postgresql-7.4 postgresql-8.0 postgresql-client postgresql-client-7.4
postgresql-client-8.0 postgresql-contrib
postgresql-contrib-7.4 postgresql-contrib-8.0 python2.3-pgsql
python2.3-psycopg python2.4-pgsql python2.4-psycopg

Please see http://www.postgresql.org/docs/techdocs.50 for further
details, or visit the referenced security advisories.

The psycopg and python-pgsql packages have been updated to
consistently use >>''

Solution:
The problem can be corrected by upgrading the affected packages to the
following versions:

Ubuntu 5.04:
postgresql: 7.4.7-2ubuntu2.3
postgresql-client: 7.4.7-2ubuntu2.3
postgresql-contrib: 7.4.7-2ubuntu2.3
libpq3: 7.4.7-2ubuntu2.3
python2.3-pgsql: 2.4.0-5ubuntu2.1
python2.4-pgsql: 2.4.0-5ubuntu2.1
python2.3-psycopg: 1.1.18-1ubuntu5.1
python2.4-psycopg: 1.1.18-1ubuntu5.1

Ubuntu 5.10:
postgresql-7.4: 1:7.4.8-17ubuntu1.3
postgresql-client-7.4: 1:7.4.8-17ubuntu1.3
postgresql-contrib-7.4: 1:7.4.8-17ubuntu1.3
libpq3: 1:7.4.8-17ubuntu1.3
postgresql-8.0: 8.0.3-15ubuntu2.2
postgresql-client-8.0: 8.0.3-15ubuntu2.2
postgresql-contrib-8.0: 8.0.3-15ubuntu2.2
libpq4: 8.0.3-15ubuntu2.2
python2.3-pgsql: 2.4.0-6ubuntu1.1
python2.4-pgsql: 2.4.0-6ubuntu1.1
python2.3-psycopg: 1.1.18-1ubuntu6.1
python2.4-psycopg: 1.1.18-1ubuntu6.1

In general, a standard system upgrade is sufficient to effect the
necessary changes. However, if you run third party applications that
use PostgreSQL, you might need further fixes, please see the details
below.

http://www.securityspace.com/smysecure/catid.html?in=USN-288-1

Risk factor : High
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2006-2313
Bugtraq: 20060523 PostgreSQL security releases 8.1.4, 8.0.8, 7.4.13, 7.3.15 (Google Search)
http://www.securityfocus.com/archive/1/archive/1/435038/100/0/threaded
Bugtraq: 20060524 rPSA-2006-0080-1 postgresql postgresql-server (Google Search)
http://www.securityfocus.com/archive/1/archive/1/435161/100/0/threaded
http://archives.postgresql.org/pgsql-announce/2006-05/msg00010.php
Debian Security Information: DSA-1087 (Google Search)
http://www.debian.org/security/2006/dsa-1087
http://security.gentoo.org/glsa/glsa-200607-04.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2006:098
http://www.redhat.com/support/errata/RHSA-2006-0526.html
SGI Security Advisory: 20060602-01-U
ftp://patches.sgi.com/support/free/security/advisories/20060602-01-U.asc
SuSE Security Announcement: SUSE-SA:2006:030 (Google Search)
http://lists.suse.com/archive/suse-security-announce/2006-Jun/0002.html
http://www.trustix.org/errata/2006/0032/
http://www.ubuntulinux.org/support/documentation/usn/usn-288-1
http://www.ubuntu.com/usn/usn-288-2
BugTraq ID: 18092
http://www.securityfocus.com/bid/18092
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10618
http://www.vupen.com/english/advisories/2006/1941
http://securitytracker.com/id?1016142
http://secunia.com/advisories/20231
http://secunia.com/advisories/20232
http://secunia.com/advisories/20314
http://secunia.com/advisories/20435
http://secunia.com/advisories/20451
http://secunia.com/advisories/20503
http://secunia.com/advisories/20555
http://secunia.com/advisories/20782
http://secunia.com/advisories/21001
http://secunia.com/advisories/20653
XForce ISS Database: postgresql-multibyte-sql-injection(26627)
http://xforce.iss.net/xforce/xfdb/26627
Common Vulnerability Exposure (CVE) ID: CVE-2006-2314
SuSE Security Announcement: SUSE-SR:2006:021 (Google Search)
http://www.novell.com/linux/security/advisories/2006_21_sr.html
http://www.ubuntu.com/usn/usn-288-3
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9947
http://www.osvdb.org/25731
http://secunia.com/advisories/21749
XForce ISS Database: postgresql-ascii-sql-injection(26628)
http://xforce.iss.net/xforce/xfdb/26628
CopyrightCopyright (c) 2006 E-Soft Inc. http://www.securityspace.com

This is only one of 38907 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.